WordPress OpenID-плагин и Nginx

С момента переноса блога на AWS прошло уже около месяца. Вроде всё работает нормально, но вот недавно мне понадобилось авторизоваться на каком-то ресурсе, который поддерживает OpenID. У меня в блоге установлены соответствующие плагины для этого: OpenID (версия 3.3.3) и XRDS-Simple (версия 1.0), который требуется для работы первого. До переноса я периодически пользовался собственным блогом для OpenID-авторизации, и все было нормально. А тут случилась оказия — я не смог авторизоваться. Ресурс сообщил мне об ошибке HTTP 404. Я сразу же понял, что дело в настройках редиректа для ЧПУ и проч. Полез в конфиг Nginx и ещё раз сверил с конфигом Apache. Всё в порядке. Переустановил плагины — результат нулевой. Тут я понял, что дело, скорее всего, в плагине. Так и оказалось — один хороший человек нашёл эту ошибку ранее и даже отправил багу разработчику. Так что, остаётся ждать реакции разработчика в следующей версии плагина. А пока я воспользовался методом, описанным главредом Сашей (да, это на его блог я поместил ссылочку выше): нужно отредактировать файл wp-content/plugins/openid/common.php на строке 619 (версия плагина — 3.3.3).

Было так:

Стало так:

Похожие статьи:

Запись опубликована в рубрике Wordpress с тэгами , , . Создать закладку на запись. Оставить комментарий или trackback: Trackback URL.

Оставить комментарий

Ваш e-mail никогда не будет опубликован или передан третьим лицам. Обязательные поля отмечены *

*
*